CTAN Comprehensive TeX Archive Network

Directory support/pkfix-helper

README
              +---------------------------------------+
              |              PKFIX-HELPER             |
              |                                       |
              |  Help pkfix process PostScript files  |
              | produced by ancient versions of dvips |
              |                                       |
              |   Scott Pakin, scott+pkfh@pakin.org   |
              +---------------------------------------+


Description
===========

pkfix is a useful utility for replacing resolution-dependent bitmapped
fonts in a dvips-produced PostScript file with the corresponding
resolution-independent vector fonts.  Unfortunately, pkfix needs to
parse certain PostScript comments that appear only in files produced
by dvips versions later than 5.58 (ca. 1996); it fails to work on
PostScript files produced by older versions of dvips.

pkfix-helper is a program that attempts to insert newer-dvips comments
into an older-dvips PostScript file, thereby making the file suitable
for processing by pkfix.  pkfix-helper can sometimes process documents
fully autonomously but does require the user to verify and, if needed,
correct its decisions.


Installation
============

pkfix-helper has essentially the same requirements as pkfix.  To run
it, you will need:

   * Perl (http://www.cpan.org/)
   * Ghostscript (http://www.cs.wisc.edu/~ghost/)
   * tftopl (comes with most TeX distributions)

Simply copy pkfix-helper to somewhere in your search path (e.g.,
/usr/local/bin/) and you should be good to go.  You may also want to
install and/or print the documentation (pkfix-helper.pdf and
encoding-samples.pdf) and install the Unix man page (pkfix-helper.1).
At a minimum, you should *read* the documentation; pkfix-helper usage
is neither completely automatic nor completely intuitive.


Copyright and license
=====================

Copyright (C) 2011, Scott Pakin

This file may be distributed and/or modified under the conditions of
the LaTeX Project Public License, either version 1.3c of this license
or (at your option) any later version.  The latest version of this
license is in:

    http://www.latex-project.org/lppl.txt

and version 1.3c or later is part of all distributions of LaTeX
version 2006/05/20 or later.

Download the contents of this package in one zip archive (691.8k).

pkfix-helper – Make PostScript files accessible to pkfix

Pkfix is a useful utility for replacing resolution-dependent bitmapped fonts in a dvips-produced PostScript file with the corresponding resolution-independent vector fonts. Unfortunately, pkfix needs to parse certain PostScript comments that appear only in files produced by dvips versions later than 5.58 (ca. 1996); it fails to work on PostScript files produced by older versions of dvips.

Pkfix-helper is a program that attempts to insert newer-dvips comments into an older-dvips PostScript file, thereby making the file suitable for processing by pkfix. pkfix-helper can sometimes process documents fully autonomously but does require the user to verify and, if needed, correct its decisions.

Packagepkfix-helper
Version1.4
LicensesThe Project Public License
Copyright2009 Scott Pakin
MaintainerScott Pakin
Contained inTeX Live as pkfix-helper
MiKTeX as pkfix-helper
TopicsFont util
...
Guest Book Sitemap Contact Contact Author